­čĹë Kuidas muuta vanade WordPressi teema uute versioonidega ├╝hilduvaks - IsItWP

Kas WordPressi administraatoribaas vajab rohkem v├Ąljalangemist?

>

Nii et soovite oma vana WordPressi teemasid ühildada WordPressi uuemate versioonidega. WordPress 3.0-ga otse nurga taga on teemade kokkusobivus palju inimesi. See on üsna lihtne: ära midagi muud.

Ma olen WordPressi teemasid teinud, kuna umbes WordPress 2.3 ilmus ja arvan, mida? Need teemad täna töötab ikka veel ja mul pole midagi vajadus et nad töötaksid WordPressi uuemate versioonidega.

  • Kas neil on? keermestatud kommentaaride funktsionaalsus (umbes 2,7)? Ning, neil on siiski ilmselt ikkagi üksiku taseme kommentaarid.
  • Kas ta kasutab post_thumbnails postitada pisipilte (umbes 2.9)? Nope, kuid mitte iga teema kasutab post pisipilte nagunii.
  • Kas neil on uus navigeerimismenüüd, kohandatud päis ja taustpildid kasutusele tulemas WordPress 3.0? Ärge unustage ja pidage meeles, et iga teema jaoks pole vajadust kohandatud tausta- või päispiltide järele.

Enamik neist omadustest pean ma valikuliseks. Võibolla keermestatud kommentaaride või uue menüüsüsteemi erandina ei vaja paljud teemad isegi selliseid asju nagu näiteks kohandatud postituste pisipildid või päisepiltid.

Nii et palun ärge muretsema, kas teie teema läheb WordPressi uuendamisel murda. Minu pistikprogrammide arendajatele pole ühtegi süütööd, kuid 99% ajaga laguneb WordPress tuumaprogrammiga, see on plugina viga (ja see tõenäoliselt tekkis kahtlast plugina kodeerimise tavade tõttu).

Kui teemale on kohandatud funktsioon, mis on vastuolus uue WordPressi funktsiooniga, võib sama teema juhtuda ka teemadega, nii et see on võimalik. See on ilmselt ainus "viga", mida ma olen kunagi kuulnud juhtumist uue tuumaprogrammiga (ja mitte iga teema kasutas get_categories funktsiooni).

Ausalt öeldes, Ma pole kunagi näinud, kuidas teema täielikult murdaja ma arvatavasti kunagi ei saa. Mul oleks huvi kuulda oma mõtteid kommentaarides, mida te arvate teemade "ühilduvuse" loomisega uute versioonidega? Kas olete näinud uue WordPressi versiooni tõttu teema pausi?

Kui soovite, et teie WordPressi teema saaks ära kasutada uusi funktsioone, mis on saadaval pärast seda, kui WordPress 3.0 on välja antud, on sellel artiklil mõned head teavet ka kohandatud taustade, pealkirjade ja menüüde integreerimiseks muu hulgas.

Like this post? Please share to your friends:
Lisa kommentaar

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: