👉 Kui installite pluginad, mida pole teie WordPressi versiooniga testitud?

Kuidas luua WordPressi blogi

Sageli küsivad meie kasutajad hoiatust, et pluginat pole nende WordPressi versiooniga testitud. Kas peaksite installima selle plugina pluginad? või leidke teine ​​plugin? Selles artiklis arutleme, miks peaksite oma WordPressi versiooniga installimata pistikprogramme installima? Mida see tähendab ja kuidas saate WordPressi kogukonda aidata?

Kui installite WordPressi administraatorialalt pistikprogrammi, võite näha hoiatust, et pluginat pole teie WordPressi versiooniga testitud.

Kuidas WordPress saab mittekontrollitud teavet?

WordPressi ametlik pluginahoidla on suurim tasuta ja avatud lähtekoodiga WordPressi pistikprogrammide kogumik. Plugina esitamisel peavad autorid esitama "readme" faili nende pistikprogrammidega. Seda readmefaili kasutab seejärel pistikprogrammide kataloog, kust pistikprogrammi genereerida.

Readme-fail sisaldab "Testitud kuni" silt, mida kasutatakse teabe kuvamiseks. Pluginate autorid peavad seda teavet ajakohastama.

See tähendab, et iga WordPressi versiooniga peaks pistikprogrammi autorid testima oma pistikprogramme ja ajakohastama nende pluginate jaoks readmefaile.

Miks mitte Plugin autoreid uuendama seda teavet?

Paljud pluginate autorid ei uuenda oma readme faile isegi siis, kui nad katsetavad oma pistikprogrammi uusima versiooniga.

Ideaalmaailmas tahaksime, et kõik pistikprogrammide autorid värskendaksid seda teavet. Kuid me ei ela ideaalses maailmas.

Pea meeles, et need pistikprogrammid on tasuta ja te ei palu autoritel neid alla laadida ja kasutada. Pluginate autorid tunnevad vähem valmis lugema faili iga versiooni värskendamiseks. Nad on tavaliselt oma täiskohaga töökohti ja makstud arendusprojekte.

Video õpetus

Telli WPBeginner

Kui sulle video ei meeldi või vajate rohkem juhiseid, siis jätkake lugemist.

Kas ma peaksin need pluginad installima?

Jah, sa peaksid. Just sellepärast, et pluginar ei värskendanud readmefaili, ei tähenda see, et nad pole oma pistikprogrammi katsetanud või plugin ei tööta WordPressi uusima versiooniga.

Kui kuulsite WPBeginneri pistikprogrammi kohta, võite kindlasti eeldada, et katsetasime pluginit WordPressi uusima versiooniga. Kui artikkel, mida te vaatate, ilmus üsna hilja, tähendab see seda, et plugin on WordPressi uusima versiooniga kooskõlas.

Teisest küljest, kui pluginat pole enam kui kaks aastat uuendatud, tähendab see, et tõenäoliselt on plugin loobutud. Sel juhul ei tohiks te plugina installida.

Oleks huvitav märkida, et paljud pistikprogrammid, mida pole enam kui kaks aastat uuendatud, töötavad ikkagi väga hästi. Siiski peaksite need installima omal vastutusel.

Kuidas sa saad aidata?

Võite installida plugina oma WordPressi saidil ja proovida seda välja. Kui see toimib ootuspäraselt, siis pöörduge tagasi plugina lehele. Logige oma WordPress.orgi kasutajanime ja parooliga sisse. Edasi kerige lehe alumisse ossa, kus näete ühilduvuse jaotist.

Valige lihtsalt WordPressi versioon, pistikprogrammi versioon ja seejärel nupul Tööd. Seda tehes annate teistele kasutajatele teada, et olete pistikprogrammi katsetanud, ja see toimib nagu lubatud.

Võite ka pistikprogrammi autoriga ühendust võtta ja palume neil värskendada oma pistikprogrammi readme-faili

Mida teha, kui plugin on purunenud?

Veelkord tahaksime oma kasutajatele meelde tuletada, et kui see on tasuta pistikprogramm, siis on plugina autor selle esitanud. Garantii pole, isegi mitte kaudne garantii sobivuse kohta. Kuid küsimus on, kuidas saate aidata kogukonnas katkestatud pistikprogramme lahendada?

Selle asemel, et jätta karmi kommentaari plugina tugitiibele, võite jätta konstruktiivse ja kasuliku tagasiside. Vaadake meie juhendit WordPressi toe nõuetekohase küsimise ja selle saamise kohta.

Enne midagi ettevalmistamist proovige installida pistikprogramm erinevas live või kohalikus WordPressi installis. Veenduge, et olete võimeline taastama sama viga ka teistes installatsioonides.

Kui olete kindel, et plugin on katki, siis lihtsalt kirjeldage tugitiibi viga ja jätke see plugina autorile või kogukonnale vastamiseks. Kui te ei saa vastust, võite proovida pistikprogrammi autorile jõuda. Enamikel pluginate autoritel on nende WordPress.org profiililehtedel kontaktteave.

Kui need sammud ebaõnnestuvad, peaksite kindlasti külastama plugina lehte ja hääletama pistikprogrammi, mis on katkenud ühilduvuse jaotises.

Loodame, et see artikkel aitas teie küsimustele vastata, kas peaksite WordPressi versiooniga installimata pistikprogramme installima.

Kui teile meeldib see artikkel, siis palun tellige meie YouTube'i kanal WordPressi videoõpikute jaoks. Võite leida ka meie vidistama ja Google+.

Vaata videot: WordPress moodulid ja pluginad

Like this post? Please share to your friends:
Lisa kommentaar

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: